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ค ำแนะน ำในกำรใช้ชุดกิจกรรม 
 

1. นักเรียนอ่ำนค ำชี้แจงหรือค ำแนะน ำและปฏิบัติตำมอย่ำงเคร่งครัด 
2. อ่ำนจุดประสงค์กำรเรียนรู้ของบทเรียนให้เข้ำใจก่อนทุกครั้ง 
3. ตั้งใจและพยำยำมท ำกิจกรรมและตอบค ำถำมทุกข้อ 
4. เม่ือท ำกิจกรรมทุกอย่ำงเสร็จแล้วให้นักเรียนท ำแบบทดสอบจ ำนวน 10 ข้อ 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

ค ำชี้แจงส ำหรับนักเรียน 
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  ด้ำนควำมรู้ 

 บอกความหมายความส าคัญของการเขียนโปรแกรม 
 อธิบายรูปแบบโปรแกรมสั่งงานได้ 
 อธิบายส่วนประกอบของหน้าต่าง Robomind ได ้

 
ด้ำนทักษะกระบวนกำร 

 ติดตั้งโปรแกรม Robomind  ได ้
 เข้าและออกโปรแกรม Robomind ได้  

ด้ำนเจตคติ 
 ตระหนักและเห็นคุณค่าของการเขียนโปรแกรม 
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แบบทดสอบหลังเรียน 
 
ค ำชี้แจง ให้นักเรียนกากเครื่องหมายกากบาท ( X ) ลงใน          ของกระดาษค าตอบในข้อที่เห็นว่า 
            ถูกต้องที่สุดเพียงข้อเดียว 
 

 1.  ข้อใดเป็นกล่าวถูกที่สุด 

ก. การเขียนโปรแกรมเป็นการใช้เวลาโดยเปล่าประโยชน์ 
ข. การเขียนโปรแกรมท าให้เราเป็นคนสมาธิสั้น 
ค. การเขียนโปรแกรมท าให้เราเป็นคนมีสมาธิ คิดรอบครอบ เป็นคนมีเหตุ มีผล 
ง. การเขียนโปรแกรมเป็นการพัฒนาความสามารถทางภาษาอังกฤษ 

2.  เหตุใดเราจึงต้องเขียนโปรแกรม  

ก. เครื่องคอมพิวเตอร์ท างานไม่เป็นถ้าไม่สั่งงาน 
ข. เครื่องคอมพิวเตอร์ไม่รู้จักภาษาท่ีใช้สั่งงาน 
ค. เครื่องคอมพิวเตอร์จะท างานตามล าดับการสั่งงานเท่านั้น 
ง. ต้องสร้างค าสั่งใหม่ให้ถ้าเครื่องคอมพิวเตอร์ไม่รู้จักค าสั่งนั้น 

3.  ข้อใดคือความหมายของโปรแกรม 

ก. ค าสั่งในภาษาคอมพิวเตอร์ 
ข. ค าสั่งใหม่ท่ีสร้างขึ้นมาเพ่ือให้คอมพิวเตอร์รู้จัก 
ค. ภาษาท่ีคอมพิวเตอร์เข้าใจและท างานตามท่ีสั่งได้ 
ง. ค าสั่งหลายๆ ค าสั่งที่น ามาเขียนรวมกันไว้อย่างมีล าดับขั้นตอน 

 4.  เหตุใดการเขียนโปรแกรมทุกครั้งต้องมี “เริ่มต้น” และ ”จบ” ก ากับไว้ 

ก. คอมพิวเตอร์ท างานไม่ได้ถ้าไม่บอกให้เริ่มท า 
ข. เพ่ือให้คอมพิวเตอร์รู้ตัวว่าจะเริ่มท างานเมื่อ เริ่มต้น และหยุดท างานเม่ือ จบ 
ค. คอมพิวเตอร์หยุดไม่ได้ถ้าไม่บอกให้หยุด 
ง. ค าสั่งมีมากมายเกินไปจึงต้องบอกให้เริ่มที่ใด และจบที่ใด 

5.  การสร้างค าสั่งใหม่จะอาศัยสิ่งใดเป็นหลัก 

ก. ค าสั่งตามท่ีใจเราต้องการ 
ข. ค าสั่งในภาษาคอมพิวเตอร์ 
ค. ค าสั่งพ้ืนฐานเดิม 
ง. การเรียงล าดับค าสั่งให้ถูกต้อง 
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6.  การสร้างค าสั่งใหม่นิยมเขียนไว้ส่วนใดของโปรแกรม 

ก. ส่วนบนของค าสั่งหลัก 
ข. ส่วนล่างของค าสั่งหลัก 
ค. ส่วนกลางของค าสั่งหลัก 
ง. ทั้งส่วนบนและส่วนล่างของค าสั่งหลัก 

7.  เว็บไซต์ที่ใช้ส าหรับโดวส์โหลดโปรแกรม RoboMind คือข้อใด 

ก. www.robomind.com/download.html 
ข. http:/robomind.net/en/download.html  
ค. www.robomind.org/en/download.htm 
ง. www.robomind.th/en/download.html 

8.  ข้อใดกล่าวถึง Script Panel ได้ถูกต้อง 

ก. เป็นหน้าต่างที่ใช้ส าหรับการแสดลผลการเคลื่อนที่ของหุ่นยนต์เสมือน 
ข. เป็นแถบเครื่องมือที่ใช้ส าหรับควบคุมการเดินของหุ่นยนต์เสมือน 
ค. เป็นแถบเครื่องมือที่ใช้ส าหรับการรันโปรแกรม  
ง.   ส่วนของพ้ืนทีส่ าหรับเขียนโปรแกรมในรูปแบบของสคริปต์เพื่อหุ่นยนต์ท างาน 

9. ข้อใดกล่าวถูกเกี่ยวกับโปรแกรม RoboMind 

ก. ไฟล์ข้อมูลที่ได้จากการบันทึกข้อมูลด้วยโปรแกรม RoboMind คือ ไฟล์นามสกุล *.irobo 
ข. ไฟล์ข้อมูลที่ได้จากการบันทึกข้อมูลด้วยโปรแกรม RoboMind คือ ไฟล์นามสกุล *.iro 
ค. ไฟล์ข้อมูลที่ได้จากการบันทึกข้อมูลด้วยโปรแกรม RoboMind คือ ไฟล์นามสกุล *.map 
ง. ไฟล์ข้อมูลที่ได้จากการบันทึกข้อมูลด้วยโปรแกรม RoboMind คือ ไฟล์นามสกุล *.irbo 

10. ข้อใดกล่าวถูกเกี่ยวกับการใช้งานโปรแกรม RoboMind 

ก. โปรแกรมสามารถส่งออกโค้ดโปรแกรม ไปใช้กับหุ่นยนต์ Inex ได้ 
ข. โปรแกรมสามารถส่งออกโค้ดโปรแกรม ไปใช้กับหุ่นยนต์ LEGO NXT ได้ 
ค. สามารถบังคับหุ่นยนต์เสมือนจากแป้นพิมพ์ (key board) ได้ 
ง. โปรแกรม RoboMind ไม่สามารถปลี่ยนแถบเมนูแสดงผลเป็นภาษาไทย 
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อยำกรู้จังท ำไมต้องเขียนโปรแกรม 

การเขียนโปรแกรมสั่งงานคอมพิวเตอร์ การท างานใดๆ ของคอมพิวเตอร์จะท าตามล าดับขั้นตอน
ค าสั่งที่วางไว้ ซึ่งเราเรียกว่า โปรแกรม และคอมพิวเตอร์จะท างานตามค าสั่งที่มีอยู่ในโปรแกรมเท่านั้น โดย
ค าสั่งแต่ละค าสั่งจะเขียนในรูปแบบโปรแกรมท่ีมีโครงสร้าง การกระท าการโปรแกรมหรือการสั่งให้
คอมพิวเตอร์ท างานตามโปรแกรมก็คือ การท างานตามค าสั่งในโปรแกรม โดยคอมพิวเตอร์จะน าค าสั่งที่เก็บ
ไว้มาแปลความหมายและกระท าตามที่ละค าสั่ง การท างานนี้จะกระท าต่อเนื่องตามล าดับจนจบโปรแกรม 
จึงจะหยุด 

ท าไมต้องเขียนโปรแกรม เพราะการเขียนโปรแกรมเป็นการสร้างงานให้กับคอมพิวเตอร์และถ้างาน
ใดต้องการให้คอมพิวเตอร์ท างานบ่อยๆ ก็ควรจะท างานเหล่านั้นให้เป็นค าสั่งใหม่ เรียกว่าฟังก์ชัน ซึ่งจะท า
ให้การเขียนโปรแกรมง่ายขึ้นและโปรแกรมก็จะสั้นลง ในการเขียนโปรแกรมถ้าคอมพิวเตรอ์ไม่เข้าใจค าสั่งก
จะหยุดท างานและแสดงข้อผิดพลาดให้ผู้เขียนโปรแกรมทราบและท าการแก้ไขข้อผิดพลาดที่เกิดขึ้น 

ข้อดีของกำรเขียนโปรแกรม 

ท ำให้เป็นคนมีเหตุผล  การเขียนโปรแกรมต้องใช้หลักการและเหตุผล ดังนั้น หากโปรแกรมไหน
ท างานผิดพลาด สิ่งแรกท่ีจะต้องมองคือการวางแผนและกระบวนการ ซึ่งเรื่องเหล่านี้เมื่อเกิดข้ึนบ่อยๆก็จะ
ท าให้กลายเป็นคนละเอียดรอบคอบมากขึ้นท าให้ มีสมำธิมำกขึ้น  การแก้ไขปัญหาที่เกิดขึ้น บางทีก็ต้อง
อาศัยความคิดที่ลุ่มลึกพอที่จะเอาไปแก้ไขแนวคิดที่ผิดพลาดได้ แต่ละครั้งก็คือประสบการณ์ท่ีใจได้สัมผัสกับ
สมาธิที่ประณีตตามล าดับ การเขียนโปรแกรมก็คือการวางแผน และการจัดการองค์ประกอบต่างๆ นี่เอง มัน
จะท าให้เราสุขุมขึ้นไปเรื่อยๆ สามรถน าไปปรับใช้กับชีวิตประจ าวันได้เป็นอย่างดี ลดความผิดพลาดต่างๆลง
ได้มาก  
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กิจกรรมที่ 1 

รูปแบบโปรแกรมสั่งงำน 

 

ค ำสั่ง ให้นักเรียนศึกษาแล้วปฏิบัติกิจกรรมในข้อ 1 – 2 ต่อไปนี้ 

 สมมติให้คอมพิวเตอร์เป็นเสมือนหุ่นยนต์ตัวหนึ่งซึ่งมีหน้าที่ปฏิบัติตามค าสั่งของเราอย่าง
เคร่งครัด โดยมีแผนที่เมืองหุ่นยนต์เป็นแผนที่ มีทิศ 4 ทิศ คือ ทิศเหนือ ทิศใต้ ทิศ ตะวันออก และทิศ
ตะวันตก โลกของหุ่นยนต์ไม่มีขอบเขตจ ากัด ทิศเหนือและทิศใต้อยู่บนแกน Y ทิศตะวันออกและทิศ
ตะวันตกอยู่บนแกน X ดังนั้นโลกของหุ่นยนต์จึงเปรียบเสมือนถนนและซอยที่ตัดกันเป็นตารางสี่เหลี่ยม 
ถนนที่ลากขึ้นไปตามแนวเหนือ ใต้ ส่วนซอยจะตัดแยกจากถนนออกไปในแนวตะวันออกและตะวันตก มุม
หรือจุดตัดจะอ้างการตัดกันระหว่างถนนกับซอย ซึ่งเป็นการตัดกันเหมือนตารางหมากรุก หุ่นยนต์จะอยู่ที่
จุดตัดเหล่านี้ซึ่งมีพิกัด ( x,y) และหันหน้าได้ 4 ทิศเท่านั้น งานของหุ่นยนต์คือส่งที่เราให้หุ่นยนต์ท า โดยมี
ค าสั่งพ้ืนฐานที่หุ่นยนต์รู้จัก 4 ค าสั่งคือ 

เดิน เป็นค าสั่งให้หุ่นยนต์เคลื่อนที่ไปข้างหน้าตามทิศท่ีมันหันหน้าไป 1 ช่องและจะคงทิศทางเดิม 

ซ้ายหัน เป็นค าสั่งให้หุ่นยนต์หันซ้าย 90 องศา โดยตัวหุ่นจะอยู่ที่จัดเดิม 

เก็บ เป็นค าสั่งให้หุ่นยนต์หยิบลูกบอล ณ ต าแหน่งที่ยืนอยู่ใส่ลงในถุง ซึ่งถ้าตรงจุดที่หุ่นยนต์อยู่ไม่มี
ลูกบอลก็จะมีข้อผิดพลาดขึ้น แต่ถ้ามีลูกบอลอยู่หลายลูกจะสุ่มเลือกมาใส่ถุงลูกเดียว 

วาง เป็นค าสั่งให้หุ่นยนต์หยิบลูกบอลจากในถุงไปวางในต าแหน่งที่ยืนอยู่แต่ถ้าหุ่นยนต์ได้รับค าสั่งนี้
ในขณะที่ไม่มีลูกบอลอยู่ในถุงก็จะเกิดข้อผิดพลาด 
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โปรแกรม 

 เร่ิมท ำงำน 

  ค ำสัง่ท่ี 1 

                         ค ำสัง่ท่ี 2 

  ………. 

  ………. 

 จบท ำงำน 

จบโปรแกรม 

 

 

 

 

 

 

โปรแกรม 

 เร่ิมท ำงำน 

  เดนิ 

                         ซ้ำยหนั 

  เดนิ 

                         ซ้ำยหนั  

  เดนิ 

                         ซ้ำยหนั 

                         เดนิ 

                         ซ้ำยหนั   

จบท ำงำน 

จบโปรแกรม 

 

 

 

 

 

รูปแบบโปรแกรมสั่งงาน หุ่นยนต์จะท างานตามค าสั่งที่มีอยู่ในโปรแกรมเท่านั้น โดยค าสั่งแต่ละ
ค าสั่งจะเขียนในรูปแบบโปรแกรมท่ีมีโครงสร้างดังนี้ 

 

 
   

 

 

 

 

 

 

ตัวอย่ำงที่ 1 โปรแกรม เดินวน 
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สมมติว่า หุ่นยนต์อยู่ในเมืองที่ต าแหน่งคู่ล าดับ ( 1 , 1 ) และหันหน้าไปทางทิศเหนือ และมีลูกบอล
อยู่ที่ต าแหน่ง ( 3 , 1) และ ต าแหน่ง ( 4, 3 ) ดังรูปให้เขียนโปรแกรมสั่งให้หุ่นยนต์ไปเก็บลูกบอล โดยใช้
ค าสั่งพ้ืนฐานทั้งสี่ คือ เดิน ซ้ายหัน เก็บ วาง 
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โปรแกรม 
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ค าชี้แจง ให้นักเรียนพิจารณาค าสั่งให้หุ่นยนต์ไปเก็บลูกบอลด้านล่าง แล้วตอบค าถามต่อไปนี้ 

 

          
          
          
          
          
          
          
          
          

0 1 2 3 4 5 6 7 8  
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1 
2 
3 
4 
5 
6 
7 
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Y 

X 

โปรแกรม 
 เร่ิมท ำงำน 
  ซ้ำยหนั 
  ซ้ำยหนั 
  ซ้ำยหนั 
  เดนิ 

  เดนิ 

  เก็บ 

  เดนิ 

  ซ้ำยหนั 

  เดนิ 

  เดนิ 

  เก็บ 

  เดนิ 

 จบกำรท ำงำน 

จบโปรแกรม 
 

 
 

1.โปรแกรมสำมำรถสัง่ให้หุ่นยนต์เดนิไปเก็บ
ลกูบอลตำมรูปภำพด้ำนบนได้หรือไม ่ถ้ำ ไม ่
เพรำะเหตใุดพร้อมทัง้แก้ไขโปรแกรมให้
สำมำรถน ำหุน่ยนต์ไปเก็บลกูบอลได้ 

................................................................... 

 
2.สดุท้ำยแล้วหุน่ยนต์หยดุ ณ ต ำแหนง่ใด 
................................................................... 
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ก ำหนดค ำสัง่ [ช่ือค ำสัง่] 

 เร่ิมต้น 

  ค ำสัง่ท่ี 1 

                         ค ำสัง่ท่ี 2 

  ………. 

  ………. 

 จบ 

 

 

 

 

 

 

ก ำหนดค ำสัง่ ขวำหนั 

 เร่ิมต้น 

  ซ้ำยหนั 

  ซ้ำยหนั  

  ซ้ำยหนั 

           จบ 

 

 

 

 

 

 

กำรก ำหนดค ำสั่งใหม่ 

การเขียนโปรแกรมสั่งหุ่นยนต์ ถ้างานใดต้องการให้หุ่นยนต์ท างานซ้ าหลายๆ ครั้ง ก็ควรจะท างาน
เหล่านั้นให้เป็นค าสั่งใหม่ เราเรียกว่า ฟังก์ชัน โดยก าหนดค าสั่งใหม่จากค าสั่งพ้ืนฐานหรือค าสั่งที่หุ่นยนต์เคย
รับรู้มาก่อนภายใต้รูปแบบ ดังนี้ 

 

 

 

 

 

 

 

 

ตัวอย่างที่ 2 การก าหนดค าสั่ง ขวาหัน 
 

 

 

 

 

 

 

 

 

 

 

 

 

www.kr
oo

ba
nn

ok
.co

m



กิจกรรมที่ 2 

กำรก ำหนดค ำสั่งใหม่ 

ค าสั่ง พิจารณารูปหุ่นยนต์ในต าแหน่งเริ่มต้น (1 , 1) และหันหน้าไปทางทิศตะวันออก จงเขียนโปรแกรม
เพ่ือให้หุ่นยนต์เก็บลูกบอล ณ ต าแหน่ง ตามรูป โดยให้เขียนโปรแกรมแบบการก าหนดค าสั่งใหม่ และตอบ
ค าถาม 

          
          
          
          
          
          
          
          
          

0 1 2 3 4 5 6 7 8  
 

   หุ่นยนต์ 

 

   ลูกบอล 
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ก ำหนดค ำสัง่ ..............  

เร่ิมต้น 

 ........................................................ 

 ……………………………………….. 

 ……………………………………….. 

………………………………………… 

………………………………………… 

จบ 

 

โปรแกรม 

           เร่ิมท ำงำน 

…………………………………………………………………………………………………………… 

…………………………………………………………………………………………………………… 

…………………………………………………………………………………………………………… 

…………………………………………………………………………………………………………… 

…………………………………………………………………………………………………………… 

…………………………………………………………………………………………………………… 

…………………………………………………………………………………………………………… 

 จบท ำงำน 

จบโปรแกรม 

1. ค ำสัง่ใหมท่ี่ใช้คือ............................................................................................ 

2. ค ำสัง่ขวำหนัมีกำรค ำสัง่พืน้ฐำนอะไรบ้ำง 

..................................................................................................................... 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

www.kr
oo

ba
nn

ok
.co

m



รู้จัก RoboMind  

การเริ่มต้นฝึกหัดเขียนโปรแกรมคอมพิวเตอร์ส าหรับนักเรียนตั้งแต่ระบบประถมศึกษาจนถึง
มัธยมศึกษามีทางเลือกจากเครื่องมือที่หลากหลาย มีภาษาต่างๆ อาทิ ภาษาโลโก้ ภาษาเบสิก ภาษาซี หรือ
โปรแกรมท่ีจัดท ามาในรูปแบบรูปภาพหรือบล๊อกลัญญาลักษณ์ ล้วนแล้วแต่มีเป้าหมายเพ่ือฝึกให้ผู้เรียน
สามารถเริ่มต้นพัฒนาโปรแกรมไปจนถึงการประยุกต์จนน าไปสู่การได้มาซึ่งโปรแกรมใช้งานได้จริง 

 RoboMind คืออะไร 

 RoboMind เป็นซอฟต์แวร์ที่พัฒนาขึ้นมาเป็นพิเศษใช้ในการเรียนรู้เทคโนโลยีการเขียนโปรกรม 
ช่วยฝึกการเขียนโปรแกรมอย่างง่าย โดยท าการเรียนรู้และทดสอบผลการท างานของโปรแกรมผ่านหุ่นยนต์
เสมือน ผู้เรียนจะได้รับการฝึกฝนเกี่ยวกับตรรกศาสตร์หรือลอจิกอย่างง่าย ฝึกฝนการเขียนค าสั่งเพื่อน ามา
สร้างเป็นโปรแกรมส าหรับการควบคุมการเคลื่อนที่ของหุ่นยนต์ เพ่ือท าการแก้ปัญหา หรือปฏิบัติภาระกิจ
ตามท่ีโจทย์ต้องการ 

 ลักษณะของโปรแกรม RoboMind จะมีหุ่นยนต์เสมือนให้ผู้พัฒนาโปรแกรมควบคุมการท างานของ
มันด้วยการพิมพ์ค าสั่งต่อเนื่องกันไป เพ่ือให้หุ่นยนต์เสมือนนี้เคลื่อนที่ตามที่ต้องการ รวมถึงท างานตาม
ชุดค าสั่งที่ก าหนดให้ ซึ่งมีค าสั่งให้วนท าซ้ า และทดสอบเงื่อนไข อันเป็นการฝึกเขียนโปรแกรมท่ีมีความ
ซับซ้อนเพ่ิมข้ึนตามล าดับ 

ส าหรับเจ้า RoboMind นี้ เป็นโปรแกรมช่วยฝึกการเขียนโปรแกรม 
แบบ ง่าย ครับเหมาะส าหรับนักเรียนที่เริ่มฝึกเขียนโปรแกรม ในระดับ 
ชั้นปฐมถึงมัธยมก่อนที่เด็กเหล่านี้จะก้าว ไปเขียน Programming 
Language อย่างเช่น c หรือ pascal ต่อไป ในระดับที่สูงขึ้น 

 
ลักษณะของโปรแกรมนั้น จะมีตัวหุ่นยนต์ (Robot) ให้เราควบคุมการ
ท างานมันด้วย การพิมพ์ค าสั่ง ทีละค าสั่งต่อเนื่องกันไป เพื่อให้หุ่นยนต์ 

(Robot)  น้อยเคลื่อนที่ไปตามทิศทางที่ต้องการและท างานต่างๆ ตามชุดค าสั่งที่มีให้ครบ  นอกจากนี้ยังมี 
ค าสั่ง ให้ท าซ้ า  และทดสอบเงื่อนไข เพ่ือการเขียนมีความซับซ้อนเพ่ิมข้ึนได้อีก 
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http://gpluspluss.files.wordpress.com/2011/07/capture.jpg


กิจกรรมที่ 3 

ติดตั้งโปรแกรม Robomind 

 

การติดตั้งโปรแกรม RoboMind มาสามารถติดตั้งได้ดังนี้ 

1. เข้าไปดาวน์โหลดโปรแกรมมาใช้งานได้ฟรี โดยเข้าไปที่เว็บไซต์ 
http:/robomind.net/en/download.html 

 
รูปภาพจาก http:/robomind.net  

 
2. หลังจากดาวน์โหลดมาได้ส าเร็จให้ด าเนิการติดตั้งตามขั้นตอนโปรแกรม 

 
 

2.1 คลิกท่ีปุ่ม Run เพ่ือด าเนินการติดตั้ง 
2.2 คลิกเลือกภาษา English 
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2.3 คลิกปุ่ม Next เพ่ือด าเนินการติดตั้งในข้ันตอนต่อไป 

 
 

2.4 อ่านข้อตกลงในการใช้งานโปรแกรม จากนั้นเลือกที่รายการ I accept the 
agreement พร้อมทั้งกดปุ่ม Next เพ่ือท าการติดตั้งโปรแกรมขั้นตอนต่อไป 
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2.5  เลือกแหล่งเก็บข้อมูลส าหรับติดตั้งโปรแกรม (โดยปกติโปรแกรมจะก าหนดให้
อัตโนมัติ) จากนั้นกดปุ่ม Next 

 

 

2.6 คลิกเลือกท่ีปุ่ม Install 
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2.7 โปรแกรมจะก าเนินการติดตั้งข้อมูล 

 
 

2.8 ติดตั้งโปรแกรมเสร็จสมบูรณ์ให้คลิกเลือกท่ี ปุ่ม Finish เพ่ือเข้าสู่การใช้งานโปรแกรม 
Robomind 

 

 

 

 

 

 

www.kr
oo

ba
nn

ok
.co

m



กิจกรรมที่ 4 

การเข้าสู่โปรแกรมและส่วนประกอบของโปรแกรม Robomind 

ค าสั่ง  ให้นักเรียนด าเนินการเข้าสู่โปรแกรม Robomind ตามข้ันต่อไปนี้แล้วตอบค าถาม 
ขั้นตอนด าเนินการ 

1. ที่หน้าจอโปรแกรม windows (Desktop) ให้นักเรียนเลือกดับเบิ้ลคลิกท่ีไปคอนโปรแกรม 
Robomind  
 

 
  

 
 
 
 
 
 
 
 
 
ค ำถำม 1.ให้นักเรียนคิดว่ามีวิธิการเข้าสู่โปรแกรม Robomind วิธีการอ่ืนพร้อมกับอธิบายวิธีการ 

เข้าโปรแกรม………………………………………………………………………………………………………..…………………..... 
      
 2. การเลิกใช้โปรแกรม Robomind ท าได้โดยการคลิกเลือกท่ีปุ่ม            เพ่ือออกจากโปรแกรม 

 
 
 
 
 
 
 
 
 
 
 
ค ำถำม 2.ให้นักเรียนคิดวิธิการออกจากโปรแกรม Robomind วิธีการอ่ืนพร้อมกับอธิบายวิธีการ 

ออกจากโปรแกรม……………………………………………………………………………………………………………………….. 
………………………………………………………………………………………………………………………………………………….. 

ไอคอนโปรแกรม RoboMind 
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กิจกรรมที่ 5 

รู้จักกับหน้าต่างโปรแกรม RoboMind 
ค าสั่ง ให้นักเรียนเปิดโปรแกรม RoboMind  ตามขั้นตอนและเรียนรู้เกี่ยวกับส่วนประกอบของหน้าต่าง
โปรแกรม RoboMind แล้วตอบค าถามต่อไปนี้ 
ขั้นตอนด าเนินการ 
 1. ด าเนินการเปิดโปรแกรม RoboMind ตามกิจกรรมที่ 4 จนได้หน้าต่างโปรแกรม RoboMind 

2. ท าความรู้จักกับองค์ประกอบต่างๆ ของหน้าต่างโปรแกรม RoboMind ดังรูป 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
รายละเอียดส่วนประกอบของหน้าต่างโปรแกรม RoboMind 

1. Menu Bar เป็นแถบรายการเครื่องมือทีทท างานแทนค าสั่งใน Menu Bar โดยแต่ละเครื่องมือจะมี
ลักษณะเป็นไอคอนรูปภาพ ที่เราสามารถคลิกเพ่ือใช้งานได้ โดยแบ่งเครื่องมือออกเป็น 4 กลุ่ม ดังนี้ 

 

 

 

 

 

 

1. Menu Bar (Ribbon) 

2.พืน้ที่เขียนโปรแกรม 

(Script Panel) 

3.พืน้ที่แสดงข้อควำม (Message Panel) 

4.แถบเมนรัูนโปรแกรม (Run Panel) 

5. แถบแสดงแผนที่หุน่ยนต์ ( World Panel 

) 
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ค ำสั่ง ให้นักเรียนช่วยกันระดมสมองหาข้อมูลเดิมลงในช่องว่างให้ถูกต้องเกี่ยวกับแถบเครื่องมือของ
โปรแกรม RoboMind ในส่วนของ คีย์ลัดและ หน้าที่การท าการท างาน 

1.1 เมนู File 
ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 
File > New Ctrl + N ใช้สร้างพ้ืนที่ใหม่บน Text Editor ส าหรับ

การเขียนโปรแกรม 

 

File > Open Ctrl + O เปิดไฟล์โปรแกรม RoboMind  

 

File > Save Ctrl + S บันทึกไฟล์โปรแกรม RoboMind 
(*.irobo) 

 

File > Save as Ctrl + Shift  
+ S 

บันทึกไฟล์โปรแกรม RoboMind เป็นไฟล์
ใหม่ (*.irobo) 

 

File > Print Ctrl + P สั่งพิมพ์โค้ดโปรแกรม RoboMind 

 

File > Export - สั่งส่งออกโค้ดโปรแกรม RoboMind เป็น
ไฟล์ที่ใช้กับหุ่นยนต์ LEGO NXT 

 

File > Open 
map 

- เป็นไฟล์แผนที่ของหุ่นยนต์ RoboMind 

 

File > Save map - บันทึกไฟล์แผนที่ของหุ่นยนต์ RoboMind 

 

File > Settings - ส าหรับปรับแต่งการแสดงผลของตัว
โปรแกรม RoboMind เช่น ภาษา การ
แสดงผลตัวอักษรของโปรแกรม เป็นต้น 

 

File > Exit Ctrl + Q ออกจากโปรแกรม RoboMind 
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 1.2 เมน ูEdit 
 

ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 

Edit > Undo  

……………. 
 

………………………………….………………… 

 

Edit > Redo  

Ctrl + Y 
 

…………………………………..…..…………… 

 

Edit > Paste  

……………. 
 

………………………………..…………………… 

 
Edit > Cut Ctrl + X 

 

……………………………..……..……………… 

 
Edit > Paste Ctrl + C 

 

……………………………..……..……………… 

 Edit > Select All  

……………. 
 

……………………………..……..……………… 

 

Edit > Insert 
 

……………. 
 

………………………………...………………… 

 

Edit > Find 
Ctrl + F 

 

……………………………………..…..………… 

 

Edit > Replace  

……………. 
 

…………………………………..……..………… 

 
1.3 เมนู View 

ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 

View > Zoom in 
 

……………. 
 

………………………………………….………… 

 

View > Zoom Out  

……………. 
ขยายแผนที่และสภาวะแวดล้อมของ
หุ่นยนต์ 

 

View > Show Grid 
 

……………. 
 

………………………………………….………… 
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ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 

View > Show radar  

……………. 
 

………………………………………….………… 

 

View > Show stats  

……………. 
 

………………………………………….………… 

 

View > Track robot  

……………. 
 

………………………..……………….………… 

 

View > Create screen 
dump 

 

……………. 
 

…………………………………..…….………… 

 
1.4 เมนู Run 

ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 

Run > Execute  

……………. 
 

……………………………………….….………… 

 

Run > Step  

……………. 
 

…………………………………………..………… 

 

Run > Pause  

……………. 
 

…………………………………………..………… 

 

Run > Stop  

……………. 
 

หยุดการท างานของหุ่นยนต์ 

 

Run > Remote   

……………. 
 

…………………………………………..………… 
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1.5 เมนู Help 
 

ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 

Help > Help topics  

……………. 
 

…………………………………………….……… 

 

Help > RoboMind  

……………. 
 

…………………………………………….……… 

 

Help > About RoboMind  

……………. 
 

…………………………………………….……… 

 
 2. ตารางแสดงรายละเอียดส่วนประกอบของหน้าต่าง (Panel) โปรแกรม RoboMind 

 

 
 
 
 
 
 
 
 
 
 
 
 

ชื่อส่วนประกอบ รำยละเอียด 

Script Panel ส่วนของพ้ืนทีส่ าหรับเขียนโปรแกรมในรูปแบบของสคริปต์เพ่ือหุ่นยนต์
ท างาน 

Message Panel พ้ืนที่แสดงข้อความข้อผิดพลาด หรือ หุ่นยนต์อาจแจ้งเหตุการณ์บางอย่าง 

Run Panel แถบเครื่องมือส าหรับการสั่งให้หุ่นยนต์ท างานตามสคริปต์ค าสั่ง  
หุยดท างาน หรือ เร่งความเร็วในการเคลือนที่ของหุ่นยนต์ 

World Panel ส่วนที่ใช้ส าหรับแสดงการท างานของโปรแกรม โดยจ าลองการท างานของ
หุ่นยนต์ 
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แบบทดสอบหลังเรียน 

 
ค ำชี้แจง ให้นักเรียนกากเครื่องหมายกากบาท ( X ) ลงใน          ของกระดาษค าตอบในข้อที่เห็นว่า 
            ถูกต้องที่สุดเพียงข้อเดียว 
 
 

1. เหตุใดเราจึงต้องเขียนโปรแกรม  
ก. เครื่องคอมพิวเตอร์ท างานไม่เป็นถ้าไม่สั่งงาน 
ข. เครื่องคอมพิวเตอร์ไม่รู้จักภาษาท่ีใช้สั่งงาน 
ค. เครื่องคอมพิวเตอร์จะท างานตามล าดับการสั่งงานเท่านั้น 
ง. ต้องสร้างค าสั่งใหม่ให้ถ้าเครื่องคอมพิวเตอร์ไม่รู้จักค าสั่งนั้น 

2. ข้อใดคือความหมายของโปรแกรม 
ก. ค าสั่งในภาษาคอมพิวเตอร์ 
ข. ค าสั่งใหม่ท่ีสร้างขึ้นมาเพ่ือให้คอมพิวเตอร์รู้จัก 
ค. ภาษาท่ีคอมพิวเตอร์เข้าใจและท างานตามท่ีสั่งได้ 
ง. ค าสั่งหลายๆ ค าสั่งที่น ามาเขียนรวมกันไว้อย่างมีล าดับขั้นตอน 

 3.   เหตุใดการเขียนโปรแกรมทุกครั้งต้องมี “เริ่มต้น” และ ”จบ” ก ากับไว้ 

ก. คอมพิวเตอร์ท างานไม่ได้ถ้าไม่บอกให้เริ่มท า 
ข. เพ่ือให้คอมพิวเตอร์รู้ตัวว่าจะเริ่มท างานเม่ือ เริ่มต้น และหยุดท างานเม่ือ จบ 
ค. คอมพิวเตอร์หยุดไม่ได้ถ้าไม่บอกให้หยุด 
ง. ค าสั่งมีมากมายเกินไปจึงต้องบอกให้เริ่มที่ใด และจบที่ใด 

   4.  การสร้างค าสั่งใหม่จะอาศัยสิ่งใดเป็นหลัก 

ก. ค าสั่งตามท่ีใจเราต้องการ 
ข. ค าสั่งในภาษาคอมพิวเตอร์ 
ค. ค าสั่งพ้ืนฐานเดิม 
ง. การเรียงล าดับค าสั่งให้ถูกต้อง 

5.  การสร้างค าสั่งใหม่นิยมเขียนไว้ส่วนใดของโปรแกรม 

ก. ส่วนบนของค าสั่งหลัก 
ข. ส่วนล่างของค าสั่งหลัก 
ค. ส่วนกลางของค าสั่งหลัก 
ง. ทั้งส่วนบนและส่วนล่างของค าสั่งหลัก 
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6. ข้อใดเป็นกล่าวถูกที่สุด 

ก. การเขียนโปรแกรมเป็นการใช้เวลาโดยเปล่าประโยชน์ 
ข. การเขียนโปรแกรมท าให้เราเป็นคนสมาธิสั้น 
ค. การเขียนโปรแกรมท าให้เราเป็นคนมีสมาธิ คิดรอบครอบ เป็นคนมีเหตุ มีผล 
ง. การเขียนโปรแกรมเป็นการพัฒนาความสามารถทางภาษาอังกฤษ 

7. ข้อใดกล่าวถูกเกี่ยวกับโปรแกรม RoboMind 

ก. ไฟล์ข้อมูลที่ได้จากการบันทึกข้อมูลด้วยโปรแกรม RoboMind คือ ไฟล์นามสกุล *.irobo 
ข. ไฟล์ข้อมูลที่ได้จากการบันทึกข้อมูลด้วยโปรแกรม RoboMind คือ ไฟล์นามสกุล *.iro 
ค. ไฟล์ข้อมูลที่ได้จากการบันทึกข้อมูลด้วยโปรแกรม RoboMind คือ ไฟล์นามสกุล *.map 
ง. ไฟล์ข้อมูลที่ได้จากการบันทึกข้อมูลด้วยโปรแกรม RoboMind คือ ไฟล์นามสกุล *.irbo 

8. ข้อใดกล่าวถูกเกี่ยวกับการใช้งานโปรแกรม RoboMind 

ก. โปรแกรมสามารถส่งออกโค้ดโปรแกรม ไปใช้กับหุ่นยนต์ Inex ได้ 
ข. โปรแกรมสามารถส่งออกโค้ดโปรแกรม ไปใช้กับหุ่นยนต์ LEGO NXT ได้ 
ค. สามารถบังคับหุ่นยนต์เสมือนจากแป้นพิมพ์ (key board) ได้ 
ง. โปรแกรม RoboMind ไม่สามารถปลี่ยนแถบเมนูแสดงผลเป็นภาษาไทย 

9. ข้อใดกล่าวถึง Script Panel ได้ถูกต้อง 

ก. เป็นหน้าต่างที่ใช้ส าหรับการแสดลผลการเคลื่อนที่ของหุ่นยนต์เสมือน 
ข. เป็นแถบเครื่องมือที่ใช้ส าหรับควบคุมการเดินของหุ่นยนต์เสมือน 
ค. เป็นแถบเครื่องมือที่ใช้ส าหรับการรันโปรแกรม  
ง. ส่วนของพ้ืนทีส่ าหรับเขียนโปรแกรมในรูปแบบของสคริปต์เพ่ือหุ่นยนต์ท างาน 

10. เว็บไซต์ที่ใช้ส าหรับโดวส์โหลดโปรแกรม RoboMind คือข้อใด 

ก. www.robomind.com/download.html 
ข. www.robomind.net/en/download.html  
ค. www.robomind.org/en/download.htm 
ง. www.robomind.th/en/download.html 
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เฉลยแบบทดสอบกิจกรรมการเรียนรู้ 
 

 
 
        
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

1. ค 
2. ค 
3. ข 
4. ก 
5. ง 
6. ค 
7. ข 
8. ง 
9. ง 
10. ข 

 

ก่อนเรียน หลังเรียน 

 

1. ค 
2. ข 
3. ก 
4. ง 
5. ค 
6. ค 
7. ก 
8. ข 
9. ง 
10. ข 
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เฉลย  
 
กิจกรรมที่ 1 รูปแบบโปรแกรมสั่งงำน 
 ข้อที่ 1 ค ำตอบอยู่ในดุลย์พินิจของครูผู้สอน เช่น 
  โปรแกรมเก็บลูกบอล 
   ซ้ำยหัน 
   ซ้ำยหัน 
   ซ้ำยหัน 
   เดิน 
   เดิน 
   ซ้ำยหัน 
   เดิน 
   เก็บ 
   เดิน 
   เดิน 
   ซ้ำยหัน 
   เดิน 
   เก็บ 
   วำง 
  จบกำรท ำงำน 
 
ข้อที่ 2   (1) ตอบ ไม่ได้ 
  (2) ตอบ พิกัด (4,3) 
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กิจกรรมที่ 2 กำรก ำหนดค ำสั่งใหม่ 
 

 โปรแกรมเก็บลูกบอล 
  ก ำหนดค ำสั่ง ขวำหัน 
   เริ่มต้น 
    ซ้ำยหัน 
    ซ้ำยหัน 
    ซ้ำยหัน 
   จบ 
  ก ำหนดค ำสั่ง หลบก ำแพง 
   เริ่มต้น 
    ซ้ำยหัน 
    เดิน 
    ขวำหัน 
    เดิน 
   จบ 
 
  เริ่มท ำงำน 
   หลบก ำแพง 
   เก็บ 
   หลบก ำแพง 
   เก็บ 
   หลบก ำแพง 
   เก็บ 
  จบกำรท ำงำน 
จบโปรแกรม 
 
1. ค ำสั่งใหม่ที่ใช้คือ  ขวำหัน 
2. ค ำสั่งขวำหันมีกำรใช้ค ำสั่งพ้ืนฐำน คือ ซ้ำยหัน ซ้ำยหัน ซ้ำยหัน 
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กิจกรรมที่ 4 

 
 ค ำถำม 1. ให้นักเรียนคิดว่ามีวิธิการเข้าสู่โปรแกรม Robomind วิธีการอ่ืนพร้อมกับอธิบายวิธีการ 

เข้าโปรแกรม  
 ตอบ คลิกที่ Start -> Program -> RoboMind 
 

ค ำถำม 2. ให้นักเรียนคิดวิธิการออกจากโปรแกรม Robomind วิธีการอ่ืนพร้อมกับอธิบายวิธีการ 
ออกจากโปรแกรม 
 ตอบ คลิกท่ีเมนู File -> Exit หรือ ใช้ Hot Key Ctrl + Q 
 

กิจกรรมที่ 5 
1.1 เมนู File 

ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 
File > New Ctrl + N ใช้สร้างพ้ืนที่ใหม่บน Text Editor ส าหรับ

การเขียนโปรแกรม 

 

File > Open Ctrl + O เปิดไฟล์โปรแกรม RoboMind  

 

File > Save Ctrl + S บันทึกไฟล์โปรแกรม RoboMind 
(*.irobo) 

 

File > Save as Ctrl + Shift 
+ S 

บันทึกไฟล์โปรแกรม RoboMind เป็นไฟล์
ใหม่ (*.irobo) 

 

File > Print Ctrl + P สั่งพิมพ์โค้ดโปรแกรม RoboMind 

 

File > Export - สั่งส่งออกโค้ดโปรแกรม RoboMind เป็น
ไฟล์ที่ใช้กับหุ่นยนต์ LEGO NXT 

 

File > Open 
map 

- เป็นไฟล์แผนที่ของโปรแกรม RoboMind 
(*.map) 

 

File > Save map - บันทึกไฟล์เป็นไฟล์แผนที่ของโปรแกรม 
RoboMind (*.map) 

 

File > Settings - ส าหรับปรับแต่งการแสดงผลของตัว
โปรแกรม RoboMind เช่น ภาษา การ
แสดงผลตัวอักษรของโปรแกรม เป็นต้น 

 

File > Exit Ctrl + Q ออกจากโปรแกรม RoboMind 
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 1.2 เมน ูEdit 
 

ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 
Edit > Undo Ctrl + Z ยกเลิกการท างาน 1 ขั้นตอน 

 
Edit > Redo Ctrl + Y ท าซ้ าการท างาน 1 ขั้นตอน 

 
Edit > Paste Ctrl + P วาง 

 Edit > Cut Ctrl + X ตัด 

 Edit > Paste Ctrl + C คัดลอก 

 Edit > Select All Ctrl + A เลือกทั้งหมด 

 
Edit > Insert - แทรกค าสั่งควบคุมหุ่นยนต์ 

 
Edit > Find Ctrl + F ค้นหาตัวอักษร 

 

Edit > Replace 
Ctrl + R แทนที่ตัวอักษร 

 
1.3 เมนู View 

ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 
View > Zoom in 

 
Ctrl + = 

เพ่ิมขนาดแผนที่และสภาวะแวดล้อม
ของหุ่นยนต์เสมือน 

 
View > Zoom Out Ctrl + - 

ย่อขนาดแผนที่และสภาวะแวดล้อม
ของหุ่นยนต์เสมือน 

 
View > Show Grid 

 
Ctrl + G 

 
แสดง / ซ่อน ตารางในแผนที่ 

 

 

View > Show 
radar 

Ctrl + W 

 
แสดงแผนที่ขนาดเล็กเพ่ือดูการท างาน
ของหุ่นยนต์เสมือน 
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ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 

View > Show stats 
 

- 

 

แสดงข้อมูลการการเดิน การตรวจพบ
วัตถุ ของหุ่นยนต์เสมือน 

 

View > Track 
robot 

 

Ctrl + T ค้นหาเป้าหมายของหุ่นยนต์เสมือน 

 

View > Create 
screen dump 

 

Ctrl + 
Print 
Screen 

 

คัดลอกรูปหน้าจอภาพของโปรแกรม 

 
1.4 เมนู Run 
 

ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 

Run > Execute - รันค าสั่ง (Script) ของโปรแกรม  

 

Run > Step - 
รันค าสั่ง (Script) ของโปรแกรมที่ละ
บรรทัด 

 

Run > Pause - หยุดรันค าสั่ง (Script) ชั่วขณะหนึ่ง 

 

Run > Stop 
 

- 
 

หยุดการท างานของหุ่นยนต์เสมือน 

 

Run > Remote  - 
ใช้ควบคุมการท างานของหุ่นยนต์
เสมือน 
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1.5 เมนู Help 
 

ไอคอน ค าสั่ง คีย์ลัด การท างาน 

 

Help > Help topics 
 

F1 

 

แสดงค าอธิบายการใช้งาน ค าสั่ง ต่างๆ
ของโปรแกรม 

 

Help > RoboMind 
- 
 

แสดงค าอธิบายการใช้งาน ค าสั่ง ต่างๆ
ของโปรแกรม ผ่านทางเว็บไซต์ 

 

Help > About RoboMind - 
แสดงข้อมูลรุ่นของโปรแกรม 
Robomind 
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